Webapp degraded performance
Incident Report for Iterable
Resolved
This incident has been resolved.
Posted Jan 16, 2024 - 13:18 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 16, 2024 - 13:13 PST
Update
We are continuing to investigate this issue.
Posted Jan 16, 2024 - 12:59 PST
Investigating
We're currently investigating reports of Iterable web app degraded performance and log in failures starting around 12 pm PT. Next update at 1:30 pm PT or sooner.
Posted Jan 16, 2024 - 12:58 PST
This incident affected: Global Web Application.