Workflow and campaign trigger failures
Incident Report for Iterable
Resolved
Our teams have continued monitoring all scheduled campaigns and workflows this afternoon following the fix and have reported no further errors related to the incident. Scheduled campaigns and workflows should continue to run successfully. Please reach out to your CSM or support@iterable.com if you have any further questions or believe you may have been impacted.
Posted Dec 15, 2020 - 14:58 PST
Update
Scheduled workflows and campaigns are now functioning normal and as expected. We are continuing to monitor our systems for any further issues and exploring further mitigations. Please reach out to support@iterable.com if you believe you were impacted. Next update at 3 pm PST.
Posted Dec 15, 2020 - 12:14 PST
Update
Scheduled workflows and campaigns are now processing. Campaigns scheduled approximately from 4:30 am - 8:20 am PST were impacted and may have failed to send. We are continuing to monitor our systems for any further issues and exploring further mitigations. Please reach out to support@iterable.com if you believe you were impacted. Next update at 12 pm PST.
Posted Dec 15, 2020 - 10:07 PST
Monitoring
We are now seeing campaigns sends go out. Our engineering team continues to investigate and monitor the cause of the workflow and campaign trigger failures for multiple customers. Next update at 10 am PST
Posted Dec 15, 2020 - 09:13 PST
Update
Our engineering team has put mitigations in place and is continuing to investigate workflow and campaign trigger failures for multiple customers. Next update at 9 am PST
Posted Dec 15, 2020 - 08:01 PST
Update
Our engineering team is continuing to investigate workflow and campaign trigger failures for multiple customers. Next update at 8 am PST
Posted Dec 15, 2020 - 07:00 PST
Investigating
Our engineering team is investigating reports of workflow and campaign trigger failures for multiple customers. Next update at 7 am PDT
Posted Dec 15, 2020 - 06:31 PST