Global API Ingestion Delay
Incident Report for Iterable
Resolved
This incident has been resolved. Please contact support if you have further questions.
Posted Jul 05, 2024 - 18:35 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 05, 2024 - 14:39 PDT
Update
The engineering team has restored service, and API ingestion processes incoming requests without lag. We are continuing to monitor API ingestions to ensure that it remains responsive. The next update will be at 6:00 PM PST.
Posted Jul 05, 2024 - 13:44 PDT
Update
The engineering team restored service at 1:00 PM PST today. The team observed the ingestion lag is still improving, but it will take up to two hours to catch up. We will continue to monitor the ingestion lag. The next update will be at 3:30 PM PST.
Posted Jul 05, 2024 - 13:44 PDT
Update
The engineering team continues working on a fix to address the performance degradation. The next update will be at 2:00 PM PST.
Posted Jul 05, 2024 - 12:06 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 05, 2024 - 10:41 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 05, 2024 - 10:37 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 05, 2024 - 10:36 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 05, 2024 - 10:35 PDT
Identified
The issue has been identified and the engineering team is working on a fix.
Posted Jul 05, 2024 - 10:30 PDT
Investigating
Beginning at approximately 9:12 AM PST, the engineering team is observing a performance degradation that is increasing the global API ingestion delay. We have identified the cause of the issue and are working to fix it. The next update will be at 12:00 PM PST or sooner.
Posted Jul 05, 2024 - 10:29 PDT
This incident affected: Global API Success and Global API Ingestion.