Investigating email send delays impacting a subset of our customers on dedicated ESPs
Incident Report for Iterable
Resolved
This incident has been resolved.
Posted Jun 24, 2024 - 18:18 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2024 - 18:17 PDT
Update
The issue is remediated and all services are operational
Posted Jun 24, 2024 - 18:16 PDT
Update
Our Engineering team is collaborating with our partners to resolve the issue of email delays. We will provide the next update by 7pm PDT.
Posted Jun 24, 2024 - 17:08 PDT
Update
Iterable engineering teams are working together on remediation steps. Emails are still processing, but delayed while no data is dropped. Next update by 5pm PDT.
Posted Jun 24, 2024 - 16:14 PDT
Update
Our Engineering team is still working on a remediation with our partners to get email sends back out. Next update by 4pm PDT.
Posted Jun 24, 2024 - 14:20 PDT
Update
Our Engineers have identified the issue and are currently working on a remediation to get email sends back to expected functionality. Next update at 2 PM PDT or sooner
Posted Jun 24, 2024 - 12:51 PDT
Investigating
We are currently investigating email send delays impacting a subset of our customers on dedicated ESPs. Emails are successfully being injected by the dedicated ESPs, but the deliveries are delayed. No messages or data is being dropped. This includes triggered and scheduled campaign sends as well as proofs. Next update by 12 PM PDT or sooner.
Posted Jun 24, 2024 - 11:24 PDT
This incident affected: Global Campaign Sends and Global Proof Sends.