Iterable WebApp UI Degredation
Incident Report for Iterable
Resolved
There have been no further reports of UI issues, and the Engineering team has seen no further errors. This incident is now resolved. Thank you for your patience. If there are questions, please reach out to Support.
Posted Dec 13, 2022 - 17:28 PST
Monitoring
The deploy has finished, and initial monitoring shows signs of improvement to the UI issues. The Engineering team will continue to monitor. Next update by 5:30pm PST.
Posted Dec 13, 2022 - 16:29 PST
Update
Our engineering team is now deploying the fix, which is planned to finish and show changes within an hour, to help alleviate the UI issues. Customers may notice a spike in these issues around the top of the hour, for example around 4:00pm. Next update will be at 4:30 PM PST or sooner.
Posted Dec 13, 2022 - 15:30 PST
Identified
We are seeing another spike of Iterable Web UI access errors occurring for multiple customers. Our engineering team has identified the cause and is working on deploying a fix. This should not be impacting actual campaign sends, Journeys, or API calls and is strictly an issue with the UI being accessed and the loading of certain Iterable web pages. Next update will be at 3:30 PM PST or sooner.
Posted Dec 13, 2022 - 14:36 PST
Update
We've determined that only Web UI was impacted here. The performance of your Campaigns and Journeys would not have been impacted.
This issue is still in the monitoring phase to ensure no further issues.
Please reach out to Support@iterable.com if you do notice any other issues.
Posted Dec 13, 2022 - 11:30 PST
Monitoring
The Web UI issues have resolved and our engineering team is still investigating the underlying cause. We will continue to monitor the platform to make sure that there is no further customer impact and will update with details when we know more. Next update at 11:30 am PST or sooner
Posted Dec 13, 2022 - 10:40 PST
Investigating
Currently we are investigating reports that the Iterable web app UI is inaccessible for multiple clients and is slow to respond for others. Our engineering team is investigating with the next update at 10:30 am PST or sooner
Posted Dec 13, 2022 - 09:28 PST
This incident affected: Global Web Application.