Users delayed processing through workflows.
Incident Report for Iterable
Resolved
Workflow processing is fully operational and no additional issues have been observed. If you have any questions, please contact your account manager or email support at support@iterable.com. A customer facing RCA will be provided upon request for those impacted.
Posted Sep 15, 2021 - 16:11 PDT
Update
We are not seeing any new stuck users as of 9:30 am PDT, moving forward we are working with customers on downstream effects of the workflow processing issue. If you have any further questions please reach out to your account manager or contact support at support@iterable.com
Posted Sep 15, 2021 - 13:27 PDT
Monitoring
We are now seeing faster workflow processing with users no longer being stuck. Engineering has identified the root cause and is working on remediation.
Posted Sep 15, 2021 - 10:32 PDT
Update
Our engineering team continues to investigate the cause of delays for users being triggered into workflows and processing through workflows. Next update at 10 am PDT.
Posted Sep 15, 2021 - 09:01 PDT
Investigating
Multiple clients have reported delays in users moving through workflows starting at around 5 am PDT. Our engineering team is currently investigating why these delays are happening. Next update at 9 am PDT.
Posted Sep 15, 2021 - 08:02 PDT
This incident affected: Cluster 19 (Workflow Processing), Cluster 13 (Workflow Processing), Cluster 12 (Workflow Processing), Cluster 14 (Workflow Processing), Cluster 11 (Workflow Processing), Cluster 21 (Workflow Processing), Cluster 20 (Workflow Processing), and Cluster 6 (Workflow Processing).