The system has finished working on backlog of data and the data is caught up. All systems are operational and have no issues. Engineering will continue to monitor the cluster performance.
Posted Jul 28, 2025 - 03:48 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 28, 2025 - 03:39 PDT
Monitoring
Ingestion lag for C18 is recovering and success rates for all services are back to normal. We will continue to monitor the cluster until the ingestion backlog has fully cleared.
Next update at 4:30 AM PDT or sooner.
Posted Jul 28, 2025 - 03:39 PDT
Investigating
Beginning at 2:30 AM PDT, Iterable Engineering detected an issue with our C18 clusters leading to delays on user updates, list uploads, user deletion, and event processing. Additionally, there were failures on API calls to endpoints such as event/track for a period of time.
Next update at 3:45 AM PDT or sooner.
Posted Jul 28, 2025 - 03:21 PDT
This incident affected: Cluster 18 (User Updates, List Uploads, User Deletions).