Cluster 9 Ingestion Delays
Incident Report for Iterable
Resolved
Our engineering team has continued to monitor cluster 9 and there have been no further issues reported.
Please reach out to your account manager or support@iterable.com if you have further questions.
Posted Nov 22, 2022 - 14:00 PST
Monitoring
As of approximately 11:35 AM PDT ingestion on c9 has fully caught up and customers should no longer be experiencing delays in events or workflow processing. Our engineering team will continue to monitor the clusters health for the next few hours before we fully resolve this incident.
Posted Nov 22, 2022 - 11:52 PST
Update
Our engineering team is continuing to scale our processing services as we work through the events ingestion backlog. At Current rates, ingestion processing should be caught up within the next hour or sooner. Until then, there will be some delays for customers on event ingestion and workflow processing. We will continue monitoring and will update at 12 PM PDT or sooner.
Posted Nov 22, 2022 - 11:02 PST
Identified
Our engineering team is continuing to allocate resources to improve ingestion processing as we work through the backlog of events. While processing speeds are picking up, customers may still be experiencing delays in event ingestion or workflow processing. Next update at 11:15 AM PDT or sooner.
Posted Nov 22, 2022 - 10:03 PST
Investigating
Our engineering team is currently investigating reports of ingestion delays on cluster 9. This is impacting list uploads, segmentation, inbound events, and user updates. No data is being dropped, only delayed. Our team is working on improving processing speed to alleviate the delays. Next update at 10:15 AM PDT or sooner.
Posted Nov 22, 2022 - 09:15 PST
This incident affected: Cluster 9 (Email Sends, Workflow Processing, Push Sends, SMS Sends, User Updates, List Uploads, User Deletions).