Email send delays for some US-hosted SparkPost traffic

Incident Report for Iterable

Resolved

SparkPost’s API issue has been resolved, and we’re no longer seeing elevated 5xx errors or increased latency. Incident has resolved.
Posted Feb 24, 2026 - 11:52 PST

Monitoring

Email sends for US-hosted customers using SparkPost were delayed due to elevated 5xx errors and increased API latency from SparkPost’s Transmissions API. EU-hosted traffic was not impacted. All customers using ESPs other than Sparkpost were similarly not impacted.

SparkPost has indicated the incident is resolved. We’re monitoring outbound email queues to ensure sends are fully processing as expected. If you continue to experience issues, please contact Support.
Posted Feb 24, 2026 - 11:51 PST
This incident affected: Global Campaign Sends.