Google Authentication Issues
Incident Report for Iterable
Resolved
Google Authentication has returned to normal functionality, and can once again be used to log into Iterable.
Posted Aug 19, 2019 - 12:56 PDT
Identified
Google Authentication continues to experience issues, so you may have difficulty logging into Iterable or other sites that rely on Google Authentication.
Posted Aug 19, 2019 - 11:55 PDT
Investigating
Google Authentication is currently experiencing issues, so you may have difficulty logging into Iterable with that method.
Posted Aug 19, 2019 - 11:33 PDT