Delayed Message Sends

Incident Report for Iterable

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 08:38 PST

Update

All processing is back to normal. We continue to monitor.
Posted Nov 18, 2025 - 07:36 PST

Monitoring

Upstream issue has been resolved. we will continue monitoring.
Posted Nov 18, 2025 - 06:57 PST

Identified

We are currently experiencing delays in processing certain message sends and exit-trigger workflows. This is due to an upstream outage affecting some of our backend components that handle message publishing.
Posted Nov 18, 2025 - 06:46 PST
This incident affected: Global System Webhooks, Global Campaign Sends, Global Proof Sends, and Global Journey Processing.