Errors fetching data feeds resulting in send skips
Incident Report for Iterable
Resolved
Impacted customers have been contacted directly with instructions on how to address the issues with Cloudflare, so at this time, we are closing the incident.
Posted Jun 04, 2022 - 17:36 PDT
Monitoring
We have continued to work with Cloudflare, but there is currently not a quick solution to unblock our IP addresses for all affected customers. Any Cloudflare customers will need to exclude Iterable IP addresses from your Cloudflare configuration, which may involve reaching out to your engineering team and Cloudflare's support team. Again, the list of IP addresses can be found here: https://api.iterable.com/ip-ranges.json.

Thank you for your patience as we worked through this issue. Please reach out to Iterable support for further questions.
Posted Jun 03, 2022 - 17:22 PDT
Update
Cloudflare are instructing us to request that our shared customers update their Cloudflare configuration to lower the security level for the zone containing Iterable IP addresses as listed here: https://api.iterable.com/ip-ranges.json.
We are continuing to work with them on alternate solutions that might not require customer intervention.
Posted Jun 03, 2022 - 16:19 PDT
Update
We are still pursuing solutions to help mitigate this issue on the Iterable end.
As a current workaround, whitelisting the below IP ranges in your Cloudflare configuration could resolve on your end.
https://api.iterable.com/ip-ranges.json
Posted Jun 03, 2022 - 14:59 PDT
Update
We are still pursuing solutions to help mitigate this issue on the Iterable end.
As a current workaround, whitelisting the below IP ranges in your Cloudflare configuration could resolve on your end.
https://api.iterable.com/ip-ranges.json
Posted Jun 03, 2022 - 14:05 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 03, 2022 - 13:39 PDT
Identified
Our engineers have identified this issue as being limited to customers that use the Cloudflare platform for their website security. We are currently working to determine the fastest mitigation steps and will share those with impacted customers once we have them.
Posted Jun 03, 2022 - 13:13 PDT
Investigating
We are currently experiencing errors when fetching data feeds. These errors are affecting the associated sends and users are receiving a send skip. The engineering team is currently investigating these errors. The next update will be at 1 PM PST or sooner.
Posted Jun 03, 2022 - 10:12 PDT
This incident affected: Cluster 5 (Email Sends, Push Sends, SMS Sends), Cluster 6 (Email Sends, Push Sends, SMS Sends), Cluster 8 (Email Sends, Push Sends, SMS Sends), Cluster 9 (Email Sends, Push Sends, SMS Sends), Cluster 10 (Email Sends, Push Sends, SMS Sends), Cluster 11 (Email Sends, Push Sends, SMS Sends), Cluster 12 (Email Sends, Push Sends, SMS Sends), Cluster 13 (Email Sends, Push Sends, SMS Sends), Cluster 14 (Email Sends, Push Sends, SMS Sends), Cluster 15 (Email Sends, Push Sends, SMS Sends), Cluster 16 (Email Sends, Push Sends, SMS Sends), Cluster 17 (Email Sends, Push Sends, SMS Sends), Cluster 18 (Email Sends, Push Sends, SMS Sends), Cluster 19 (Emails Sends, Push Sends, SMS Sends), Cluster 20 (Email Sends, Push Sends, SMS Sends), and Cluster 21 (Email Sends, Push Sends, SMS Sends).