Journey processing delays
Incident Report for Iterable
Resolved
The Engineering team has deployed a fix. We will continue to monitor the issue to make sure the mitigations are successful. If you have any questions please do not hesitate to reach out to your account manager or email support@iterable.com
Posted May 19, 2022 - 21:15 PDT
Investigating
Our engineering team is currently investigating journey performance issues, currently working on improving processing speeds. Next update at 9:00 pm PT or sooner.
Posted May 19, 2022 - 19:52 PDT
This incident affected: Cluster 6 (Workflow Processing) and Cluster 5 (Workflow Processing).