Email Target API Failures
Incident Report for Iterable
Resolved
The fix has been rolled out and /api/email/target calls are now returning a 200 response with normal response bodies. If you have any further questions, please do not hesitate to reach out to your account manager or email support@iterable.com
Posted Mar 24, 2022 - 19:01 PDT
Update
We are continuing to monitor the next update will be at 7:30 PM PST or sooner.
Posted Mar 24, 2022 - 18:30 PDT
Monitoring
Our engineering team has a deployed a fix and we have confirmed that /api/email/target calls are now returning a 200 response with normal response bodies. We will continue to monitor and the next update will be at 6:30 PM PST.
Posted Mar 24, 2022 - 17:52 PDT
Update
After an initial investigation the /api/email/target calls are successful and returning 200s, but are not returning our normal response bodies. We ask customers utilizing the /api/email/target API to either pause all calls to that endpoint, or pause retry logic on empty response bodies, until we roll out a fix. We will have the next update by 6:30 PM PST or sooner.
Posted Mar 24, 2022 - 17:37 PDT
Investigating
At approx 4:40 PM PST our team began investigating reports of silent API failures for our /api/email/target endpoint across all customers. We are continuing to investigate and will provide the next update by 6 PM PST or sooner.
Posted Mar 24, 2022 - 17:15 PDT
This incident affected: Global API.